karaoke software for windows 7, Vista, XP
Sales Call/Text:
919-870-0344
Karaoke Software for Everyone
Including Singers & Hosts
Vocal Removal Tools

Remove Vocal Example Songs

Cyber Weeek Deals!
40% off all Software!

(Includes upgrades over $40.00)
Coupon Code: 124016

Our Website is in the process of being Moved from an older server to newer one. This has now caused issues with our SSL Certificate stating that it is not secure. It is secure, so any credit card details will be safe when you place an order.

      Using Internet Explorer you will see this image.



      Click Continue to this webpage (not recommended) to continue to our site.


      Using Google Chrome you will see this image.



      Click Advanced then click Proceed to www.mtu.com (unsafe).



15% off all MTU Karaoke Ultrabook Systems!
(Laptop prices reflect discount)
Remaining: 


Microeditor 5.0-5.2c Software Changes

Version Release Date
Project Compatibility
V5.3-V5.5 June 24, 2002 & Prior
V5.2c August 20, 1999
V5.2b-nt February 26, 1999
V5.2a February 9, 1999
V5.2 November 30, 1998
V5.1b August 28, 1998
V5.1a January 13, 1998
V5.1 October 10, 1997
V5.0 August 18, 1997
V2.4-V2.7b May 20, 1997 & Prior

Version 5.2c

Project Compatibility

Projects created under Microeditor Versions 2.0 to 2.7b are upward compatible with Microeditor Version 5.2c. Projects created under Version 5.2c are downward compatible to 5.1b and lower only if the following conditions are met:

  1. Microeditor 5.1 and higher automatically stores the project mix file in the old format (64K buffer limit) if none of the limitations below are exceeded. However, the project will automatically extend beyond this limit whenever required, then storing in a new project format. MicroCD 2.1x will not process the new project format, but Version 2.2 and higher will. The Split Project command can be used to create smaller projects that save under the old format if all criteria are met.
  2. Long filenames are not used (i.e. the 8.3 DOS filename format is followed)
  3. No Combined Segments exist (do not use the Combine Group Segments command)
  4. Projects with 3 digit Group numbers in segments are downward compatible with versions V5.1b to 2.6, but 2.5 only supported 2 digits and lower versions did not support group numbers at all
  5. The number of segments, zones or flags each does not exceed 2,048 (in V5.1a and higher this can be 32,767 each - the Split Project command can be used to overcome this)
  6. Projects with 24-bit resolution or with 24-bit sound files are NOT downward compatible. However, 16-bit projects are if they do not contain segments from 24-bit sound files.
  7. Any one of the CLIST, PLIST and TLIST in the project mix file (pasted to the Windows clipboard by pressing the F12 function key with the project open) must not have exceeded 65,536 count (the Split Project command can overcome this)

Version 5.2c New Features

  1. InstallShield Program - The Install program has been upgraded to use InstallShield to install directly under Windows 95, 98. This will be upgraded in Microeditor V5.3 to install under Windows NT 4.0.
  2. AddOn Interface Code Structure - This new structure allows linking major features into Microeditor without modifying the core code. This is how Karaoke Pro is linked in. In V5.3 the Video window and Direct-X plug-in structure will use this interface.
  3. Remove Skip Zone Warning Dialog Box - The Unable to adjust one or both ends of marking warning dialog box when adding skip zones has been removed. It usually appeared in silent areas where it doesn't matter at all, and in true stereo segments where there is no clear zero crossing on both tracks where the user could do no better.
  4. Change Flag Entry Default State - The Flag field in the Project Screen now defaults to leave the state the user has selected when closing and opening Microeditor. Segment or project flag inserting is the same as before.
  5. Make Tab and Shift-Tab Stop Waveform Drawing - These now behave the same as the + and - keys. Pressing Tab in any waveform view will stop the waveform drawing, move the view window to the new indicated position to the left or right and start re-drawing the waveform at the new location. Pressing Tab multiple times will move the view window without showing the waveform until Tab is not pressed again.

Version 5.2c Changes

Version 5.2c Bug Fixes

Page Top

Version 5.2b-nt

Version 5.2b-nt requires a Krystal DSP Engine and Windows 95, 98 or NT 4.0 with Service Release 4 installed. The NT version must be requested at time of order. Notable omissions in the NT version include:

  1. The core installation must be done under Windows 95 or 98 (requires a dual boot system with NT also)
  2. The install program requires executing an .exe program to make the required Registry installation
  3. Microsync is not supported, thus it cannot sync-lock resolve to SMPTE or Video
  4. Krystal cannot be installed as the NT Multimedia Sound Device

This version requires an SVGA resolution display with 256 colors. If the whole Microeditor screen doesn't appear, configure Windows to use the SVGA 800x600 resolution Video driver.

Project Compatibility

Projects created under Microeditor Versions 2.0 to 2.7b are upward compatible with Microeditor Version 5.2a. Projects created under Version 5.2a are downward compatible to 5.1b and lower only if the following conditions are met:

  1. Microeditor 5.2a (5.1 and higher) automatically stores the project mix file in the old format (64K buffer limit) if none of the limitations below are exceeded. However, the project will automatically extend beyond this limit whenever required, then storing in a new project format. MicroCD 2.1x will not process the new project format, but Version 2.2 and higher will. The Split Project command can be used to create smaller projects that save under the old format if all criteria are met.
  2. Long filenames are not used (i.e. the 8.3 DOS filename format is followed)
  3. No Combined Segments exist (do not use the Combine Group Segments command)
  4. Projects with 3 digit Group numbers in segments are downward compatible with versions V5.1b to 2.6, but 2.5 only supported 2 digits and lower versions did not support group numbers at all
  5. The number of segments, zones or flags each does not exceed 2,048 (in V5.1a and higher this can be 32,767 each - the Split Project command can be used to overcome this)
  6. Projects with 24-bit resolution or with 24-bit sound files are NOT downward compatible. However, 16-bit projects are if they do not contain segments from 24-bit sound files.
  7. Any one of the CLIST, PLIST and TLIST in the project mix file (pasted to the Windows clipboard by pressing the F12 function key with the project open) must not have exceeded 65,536 count (the Split Project command can overcome this)

Version 5.2b-nt New Features

Version 5.2b-nt Changes

  1. Microeditor Compatibility with Other Programs - Microeditor's VXD virtual device driver was incompatible with some programs from Macromedia; notably Director, Freehand, and Painter. This has been upgraded. If you find other programs Microeditor will not work with, please let us know.
  2. Undo Renamed to Undo Last - This now reflects its true operation.
  3. Utilities Menu Renamed to Tools Menu - This was done in the Project and Create screens to follow the Windows standards.
  4. Play Menu I/O Options Command Deleted - This redundant command is now only in the Defaults menu.
  5. Group Icon Renamed - The GRP DIS icon title was confusing as labeled. Now it shows GRP ENAB when gray and groups are enabled. When depressed, it changes to GRP DIS with a red background, and disables grouping to process the segments individually.
  6. Disk Free Field in Project Screen - This field now factors the open project 16- or 24-bit resolution status when computing the remaining time available on the active hard drive.
  7. Project Backup MBK File Use Streamlined - Whenever a change is made in the open project, it backs up in the MBK file. Exiting the project deletes the MBK file. However, if power is lost or the computer locks up, the MBK file remains safe on disk. When opening a project MIX file, if its MBK file exists, it opens instead. The warning-selection dialog box no longer appears. The original MIX file is renamed to OLD.
  8. DAT Backup/Restore Commands Handle 24-Bit Files - The DAT archiving commands were upgraded to archive and restore all files for 24-bit projects. Standard CDROM backup programs also handle 24-bit files and projects.
  9. Help System Upgraded with Dialog Help - All dialog boxes now have a ? at the upper right corner. Clicking this and any field, button, clickbox, etc. in that dialog box presents a pop-up help message. All details of using dialog boxes are removed from the main Help pages, making this information available when you discover you need it. The primary Help system now gives a better overview and includes a Table of Contents with books and topics.

Version 5.2b-nt Bug Fixes

  1. The Help Icon would not link to the Help file when any other item was clicked on the display. It is now fixed.
  2. Shift+Left/Right Arrow Keys - This locates skip or amp zones. Under certain conditions, this would not work properly. This is now fixed.
Page Top

Version 5.2a

Version 5.2a New Features

  1. Display Defaults dialog box - This command has 3 changes within:

    • Show Skip Zone dialog box after zone insertion check box enables the dialog box to appear when the Skip Z icon or the Insert Skip Zone command execute. The default is to not show the dialog box.
    • Show Amp Zone dialog box after zone insertion check box enables the dialog box to appear when the Amp Z icon or the Insert Amp Zone command execute. The default is to show this dialog box.
    • Keep marking after zone insertion check box replaced the prior Keep/Erase marking on center mouse button radio buttons. The default is to remove the marking after either zone is inserted. Clicking this on does not erase the marking after the zone is inserted.

Version 5.2a Changes

Version 5.2a Bug Fixes

  1. The Compressor/Limiter Command second channel fader did not work. It is now fixed.
  2. Split Segment, Amp and Skip Zones - These operations now work properly in 24-bit segments. In 5.2 a variable amount of square wave distortion appeared before the edit. This is now fixed.
  3. Normalize Command and Skip Zone Could Randomly Lock the Computer. There was a conflict with the Multimedia Device Driver that would Lock up with Normalize and certain conditions with the Auto-Adjust when entering a Skip zone. This has been fixed.
  4. Mark Icon Color - This icon now turns yellow when the Keep marking after zone insertion check box is enabled. Before, marking remained active, but the icon color remained gray, which was confusing.
  5. Mix Defaults Set to Zero - Microeditor no longer crashes during audition play when high and low mix defaults are both set to zero.
  6. Fixed Shift-left Arrow Key - This zone search function no longer freezes under certain conditions.
  7. Fixed occasional noise occurring in 24-bit projects - This could occur when inserting skip and amp zones.
Page Top

Version 5.2

Version 5.2 New Features

  1. The Help System has been massively upgraded to include;

    • The Contents structure is totally redone including what's new and changed
    • The Main Help context sensitive pages that use the Help engine are massively upgraded
    • A totally new Dialog Help system is now available in each dialog box using the upper right corner "?" or right clicking any field
  2. 24-Bit Projects - The selection for a project is set in the File menu New command. In a 24-bit project, left-clicking the Rec A or Rec AB Icon automatically creates 24-bit default sound files regardless of the digital or analog port being recorded. When playing a 24-bit project, the I/O Options command sets whether digital outputs are 16- or 24-bit resolution. Segments from both 16- and 24-bit sample files can be in a 24-bit project. 24-bit projects store 24-bits sound blocks to retain the full sonic resolution. All effects (EQ, Compressor/Limiter, Invert Phase, Burn Edits to Segment) and Group Combining compute 24-bit resolution effect layers.
  3. 16-Bit Projects - Since 1989, Microeditor has done all math calculations with 24 bit registers and 56-bit accumulators, but dither-rounded back to 16-bits for mixing. Now, all segments in 16-bit projects compute and dither-round to 24-bits for dynamic (on-the-fly) mixing and output, retaining the full sonic range and clarity of 24-bit precision math. The I/O Options command sets whether AES/EBU or S/PDIF digital outputs are 16- or 24-bit resolution. Segments from both 16- and 24-bit sample files can be in a 16-bit project. All effects and Group Combining compute 16-bit resolution effects layers. When static mixing (usually beyond 12-15 stereo segments overlapped) is required, it dither-rounds and stores 16-bit layers to disk.
  4. 24-Bit Static Mixing and Effects Layers - Overlapping segments in 16- or 24-bit projects can be from 16- and 24-bit sound and wave files. 16-bit projects compute and store 16-bit sound blocks on the hard drive for static mix and effect layers.
  5. 24-Bit Effects Send - This EFX menu command now supports 24-bit samples using the Krystal DSP Engine AES/EBU and SPDIF I/O ports.
  6. 32-bit Floating Point Sound Files - Sound files now support IEEE 32-bits floating-point format for storing 24-bit sample data. These require double the hard drive storage as 16-bit integer format sound or wave files.
  7. Long Filenames - Microeditor fully supports filenames up to 128 characters in all appropriate fields.
  8. The View Window has a new look.
  9. Open Command Uses Explorer Dialog Box - This allows opening any drive and folder, deleting files and creating folders. A new Bit Resolution field shows this for a selected project.
  10. New Command Uses Explorer Dialog Box - This allows creating a new project on any drive or folder, deleting files and creating folders. A Bit Resolution field now sets this parameter for the project being created. A Save as default settings check box allows changing the defaults that this dialog box shows. A Set Mix default directory check-box allows changing the default folder.
  11. Sample Rate/Tracks Command Removed - The defaults are now set in the Files menu New command.
  12. Record and Files Dialog Boxes Handle 24-bits - The Record New Segments dialog box (right click the record icon) is now titled Record. The Files Dialog Box that appears when the Files button is clicked now uses the new Windows Explorer open dialog for access to any drive and folder, deleting files and creating new folders. It allows recording 16-bit sound and wave files in a 16-bit project, and 24-bit sound files in a 24-bit project.
  13. Long Filenames - Microeditor fully supports filenames up to 128 characters in all appropriate fields.
  14. Record and Files Dialog Boxes Handle 24-bits - The Record New Segments dialog box (right click the record icon) is now titled Record. The Files Dialog Box that appears when the Files button is clicked now uses the new Windows Explorer open dialog for access to any drive and folder, deleting files and creating new folders. It allows recording 16-bit sound and wave files in a 16-bit project, and 24-bit sound files in a 24-bit project.
  15. Keep Marking After Zone Inserts - This new check box in the Display Defaults command enables the marking to remain after a zone is inserted with marking. The marking can then be used to create zones in overlapping segments at the identical location and duration. When enabled, the mouse center-button inserts skip zones and the marking remains.
  16. Totally New Zones Dialog Box - The Amp Zone and Skip Zone dialog boxes are now combined as one modeless dialog. Modeless allows this dialog to be visible, and still click into the project to mark or do other operations. Next and Prior buttons in the dialog instantly jump to adjacent zones to see or modify them. Defaults are set in the dialog and can be applied instantly to the selected zone or a new inserted one. The mouse center button still inserts skip zones.
  17. Zone Defaults Command Deleted - The new Zones dialog box no longer needs this separate command.
  18. Project Backup MBK File Use Streamlined - Whenever a change is made in the open project, it backs up in the MBK file. Exiting the project deletes the MBK file. However, if power is lost or the computer locks up, the MBK file remains safe on disk. When opening a project MIX file, if its MBK file exists, it opens instead. The warning-selection dialog box no longer appears. The original MIX file is renamed to OLD.
  19. DAT Backup/Restore Commands Handle 24-Bit Files - The DAT archiving commands will upgrade to archive and restore all files for 24-bit projects. Standard CDROM backup programs also handle 24-bit files and projects.
  20. Help System Upgraded with Dialog Help - All dialog boxes now have a ? at the upper right corner. Clicking this and any field, button, click box, etc. in that dialog box presents a pop-up help message. All details of using dialog boxes are removed from the main Help pages, making this information available when you discover you need it. The primary Help system now gives a better overview and includes a Table of Contents with books and topics.
  21. Hot Keys - New keys have been added to make working easier:

    • C=Display Create Segment open dialog box
    • E=Display Edit view (pressing E in Edit returns to the Project view)
    • G=sets the captured group number into the selected segment
    • Ctrl-G captures the group number of the selected segment and programs it for the G key
    • L=Lock selected segment
    • M=Mute selected segment
    • Ctrl-M=Mute selected group
    • P=Play selected group segments only, starting at the play cursor
    • S=Split selected segment at the play cursor

Version 5.2 Changes

  1. Disk Free Field in Project Screen - This field now factors the open project 16- or 24-bit resolution status when computing the remaining time available on the active hard drive.
  2. Group Icon Renamed - The GRP DIS icon title was confusing as labeled. Now it shows GRP ENAB when gray and groups are enabled. When depressed, it changes to GRP DIS with a red background, and disables grouping to process the segments individually.
  3. Undo Renamed to Undo Last - This now reflects its true operation.
  4. Utilities Menu Renamed to Tools Menu - This was done in the Project and Create screens to follow the Windows standards.
  5. Play Menu I/O Options Command Deleted - This redundant command is now only in the Defaults menu.
  6. Microeditor Compatibility with Other Programs - The VXD virtual device driver was incompatible with some programs from Macromedia; notably Director, Freehand, and Painter. This has been upgraded. If you find other programs Microeditor will not work with, please let us know.

Version 5.2 Bug Fixes

  1. Record Dialog Box File Flags Did Not Insert - When file flags are enabled in the record dialog box, they now correctly store in the sound file header.
  2. Fix Audio Pop with Audition Play - Under some conditions on some Microsound workstations, with Audition play or Spacebar play, when the mouse button or Spacebar is pressed or released an audible pop could occur. This did not matter whether playing through the analog or digital port I/O output on the Krystal or external I/O Module. Also if play had been from the analog port, then the digital port is selected and played, the pop occurs immediately. This did not exist in V2.7b. This has been fixed.
  3. Overdub with Marking Would Lockup - Using a Pentium or Pentium II computer at 233MHz or faster, Microeditor exhibited random lockups when overdub with marking was terminated early with the Spacebar. This is fixed.
  4. Overdub in Mono Project Didn't Work - In a mono project, overdub would not perform correctly. Using a Pentium or Pentium 2 computer with greater than 200MHz clock speed, Microeditor exhibited random lockups when Overdub with marking is terminated early with the Spacebar. This is now fixed.
  5. Split Segment Deletes Flags Bug - If a segment flag is at the very first or last sample in a segment, executing the Split Segment command would delete the flag(s). The flags now remain after the segment is split.
Page Top

Version 5.1b

Version 5.1b New Features

  1. Windows NT 4.0 Operation - A special version of V5.1 is available that runs with Windows NT. This must be requested at time of order. Notable omissions include:

    • No install program, but there is an .exe program that makes the required Registry installations
    • No Microsync support exists, thus it cannot sync-lock resolve to SMPTE or Video
    • No Multimedia Sound Device driver exists, thus other programs cannot play audio through the Krystal DSP Engine
    NOTE: MTU does not currently offer customer support for NT. The user must personally understand and be able to solve NT problems.

Version 5.1b Changes

Version 5.1b Bug Fixes

Page Top

Version 5.1a

This release requires an SVGA resolution display and uses 256 colors. If the whole Microeditor screen doesn't appear, configure Windows to use the SVGA 800x600 resolution Video driver.

V5.1a requires the Krystal DSP Engine and Windows 95 or NT SR4 to run. The new features and changes are not described in the Microeditor 5.0 manual that comes with 5.1a. Regretfully, our printing company recompiled the 5.0 manual and did not update the Index References, which are thus off by several pages. Please forgive this unexpected problem.

Project Compatibility

Projects created under Microeditor Versions 2.0 to 2.7b are upward compatible with Microeditor Version 5.1a. Projects created under Version 5.1a are downward compatible only if the following conditions are met:

  1. Microeditor 5.1 and higher automatically stores the project mix file in the old format (64K buffer limit) if none of the limitations are exceeded. However, the project will automatically extend beyond this limit whenever required, then storing in a new project format. MicroCD 2.1x will not process the new project format, but Version 2.2 and higher will. The Split Project command can be used to create smaller projects that save under the old format if all criteria are met.
  2. Long filenames are not used (i.e. the 8.3 DOS filename format is followed)
  3. No Combined Segments exist (do not use the Combine Group Segments command)
  4. Projects with 3 digit Group numbers in segments are downward compatible with versions 2.6 to 5.1, but not 2.5 or lower
  5. The number of segments, zones or flags each does not exceed 2,048 (in V5.1a and higher this can be 32,767 each - the Split Project command can be used to overcome this)
  6. Any one of the CLIST, PLIST and TLIST in the project mix file (pasted to the Windows clipboard by pressing the F12 function key with the project open) must not have exceeded 65,536 count (the Split Project command can overcome this)

Version 5.1a New Features

  1. Windows NT 4.0 Operation - A special version of V5.1 is available that runs with Windows NT. This must be requested at time of order. Notable omissions include:

    • No install program, but there is an .exe program that makes the required Registry installations
    • No Microsync support exists, thus it cannot sync-lock resolve to SMPTE or Video
    • No Multimedia Sound Device driver exists, thus other programs cannot play audio through the Krystal DSP Engine
    NOTE: MTU does not currently offer customer support for NT. The user must personally understand and be able to solve NT problems.
  2. Play Group Function - A selected Group will play by Shift-Left clicking the Play Icon. Play starts from the current play cursor location. Even if other segments are overlapping, only the selected Group segments play.The GRP DIS Icon must be off (gray background).

Version 5.1a Changes

  1. Long Filenames Can Be Used - Microeditor will accept long names. For compatibility, Projects filenames have a limit of 128 characters. There are still many fields in Microeditor that do not show the long names. Additionally, MicroCD and Microtools do not support long names. If long names are used, the project will not be downward compatible with 5.0 or earlier versions.
  2. Segments, Zones, or Flags in a Project - V5.1a allows up to 32,768 Segments, 32,768 Zones, and 32,768 Flags (Segment + Project) in a single project. V2.5 to V5.1 allowed up to 2,048 each. When saving a 5.1a project, if the number of segments, zones and flags are each less than 2,048, the project mix file automatically saves in V2.5 to V5.1 format. Exceeding any of the 3 limits saves the project as a new version loadable only by V5.1a and higher. This now allows extremely large projects.

Version 5.1a Bug Fixes

  1. Panasonic SV3700/3900 DATs Stop While Recording - Previously, these DAT recorders would drop out of record in 5-10 seconds when recording from the Krystal digital output. This now works.
  2. Pops at the Start or End - These should no longer occur when playing out the Krystal digital audio output ports (AES/EBU or S/PDIF). Previously, some Krystals added this sound.
  3. Writing File Flags to Sound Files - This operation failed in V5.1 and now works.
  4. Move Display Command Lockup - Using this command no longer shows the (53) Unable to allocate sound file data structure error message. Earlier on some systems, this would occasionally appear and lock Microeditor when the play cursor was outside the View Window.
  5. Audition and EFX Menu Play Operations Work - Previously, when used with Microsync and the Sync field was set to SMPTE or Video, if the background color flickered red or yellow, these play operations sometimes failed to terminate.
  6. Opening V2.4 Projects - These projects would not properly translate up in V5.1. This has been fixed. Previously an (208) Invalid flag list contents error message would appear.
  7. NOTE: When using a Microsound external I/O Module that does not contain a digital I/O board, changing either the Play or Record I/O port to DA (Digital AES/EBU) or DS (Digital S/PDIF) AUTOMATICALLY SWITCHES TO KRYSTAL I/O for both ports. For example, if the I/O Option command I/O selection is I/O Module, changing the record port to AES/EBU or SPDIF will play out the Krystal analog port if monitoring.
  8. Using the Effect Send Icon, if both play and record are set to digital, the output sample rate is crystal controlled, as opposed to synchronizing to the digital record input. Thus, any attached external digital unit must slave to Microsound's digital clock output (normal operation). In all other cases of digital recording, any Microsound output (analog or digital) synchronizes to the incoming digital signal.
Page Top

Version 5.1

This release is primarily a "platform upgrade" that allows running on Windows NT 4.0. However, MTU does not currently provide customer support for operation with Windows NT. The user must be capable of handling all problems themselves. MTU will provide full support with Windows NT 5.0 early in 1999.

Microeditor 5.1 requires an SVGA resolution display and uses color. If the whole Microeditor screen doesn't appear, configure Windows to use the SVGA 800x600 resolution Video driver. V5.1 requires the Krystal DSP Engine and Windows 95 to run. The new features are not described in the Microeditor 5.0 manual that comes with 5.1. Regretfully, the 5.0 manual was reset by the printing company who did not update the Index References. Thus, all Index referenced page numbers are off by several pages. Please forgive this unexpected problem.

Project Compatibility

Projects created under Microeditor Versions 2.0 to 2.7b are upward compatible with Microeditor Version 5.1. Projects created under Version 5.1 are downward compatible only if the following conditions are met:

  1. Microeditor 5.1 and higher automatically stores the project mix file in the old format (64K buffer limit) if none of the limitations are exceeded. However, the project will automatically extend beyond this limit whenever required, then storing in a new project format. MicroCD 2.1x will not process the new project format, but Version 2.2 and higher will. The Split Project command can be used to create smaller projects that save under the old format if all criteria are met.
  2. Long filenames are not used (i.e. the 8.3 DOS filename format is followed)
  3. No Combined Segments exist (do not use the Combine Group Segments command)
  4. Projects with 3 digit Group numbers in segments are downward compatible with versions 2.6 to 5.0, but not 2.5 or lower
  5. Any one of the CLIST, PLIST and TLIST in the project mix file (pasted to the Windows clipboard by pressing the F12 function key with the project open) must not have exceeded 65,536 count (the Split Project command can overcome this)

Version 5.1 New Features

  1. Multiple Microeditor Copies Run One at a Time - With a single Krystal DSP Engine, only one copy of Microeditor can run at a time. However, multiple copies can be loaded and switched to instantly (Alt-Tab), each doing separate operations or having different projects open.
  2. Multiple Microeditor Copies Run Simultaneously - With multiple Krystal DSP Engines in the same computer, multiple copies of Microeditor can run at the same time. It is even possible to be recording a file on one copy and open and edit that same file on the second copy. Further tests are required to prove CD-Recording can be done simultaneously while recording or editing/playing on a second Microeditor.
  3. Background Tape Backup - Using an Exabyte Tape drive, it is possible to execute a tape backup of disk files (except the sample files being recorded or projects being created) and return to Microeditor and perform recording (4 channels has been proven) or project editing with up to 4 overlapping segments mixing live... all while backing up.
  4. WAV Files - These sample files can now be recorded directly from Microeditor in the Record New dialog box. This is the first step in fully supporting WAV files and 3rd party DSP software packages.
  5. Backup & Restore to DAT Commands - These now backup and restore WAV files used in a project.

Version 5.1 Changes

  1. 64K Buffer Limits Removed - This limit was rarely hit except by those doing very large projects. The limit has been increased to 1,000,000 which should give more than adequate margins for even the largest projects.
  2. Windows Interrupts - In Microeditor 5.1, the interrupt handling has been completely rewritten. The code that has worked flawlessly for 8 years did not perform as well under 32-bit Windows 95 operation. It is now fully upgraded to maximum performance. As a result, other programs running at the same time also perform better.

Version 5.1 Bug Fixes

  1. No bug repairs are documented.
Page Top

Version 5.0

Microeditor 5.0 software is primarily a "platform upgrade" that opens the door for major new feature expansion. V5.0 requires an SVGA resolution display and uses color. If the whole Microeditor screen doesn't appear, configure Windows to use the SVGA 800x600 resolution Video driver. V5.0 requires the Krystal DSP Engine and Windows 95 to run. This is the first Microeditor version that will not run on Windows 3.1x. The added features are described in the Microeditor 5.0 manual. Regretfully, all Index referenced page numbers are off by several pages. Please forgive this unexpected problem.

Version 5.0 New Features

  1. WAV Files - These sample files can now be recorded directly from Microeditor in the Record New dialog box. This is the first step in fully supporting WAV files and 3rd party DSP software packages.
  2. Backup & Restore to DAT Commands - These now backup and restore WAV files used in a project.
  3. Field Text and Background Colors Customizable - Screen field colors are now user settable, customized for each Microeditor icon.

Version 5.0 Changes

  1. Performance - This is greatly improved as interrupts are processed much faster, running in 32-bit code. The performance improvements are impressive:

    • Between 13-19 fade ramps on stereo segments can compute live on-the-fly simultaneously in overlapped segments.
    • Waveform Drawing Speed - This is more than 2 times faster that earlier releases. A stereo 44.1KHz waveform 30 seconds long takes under 3 seconds to draw in Edit Segment mode.
    • Up to 15 stereo overlapped segments (from stereo files @ 44.1KHz) can mix live on-the-fly with one EIDE drive (expect 10-15 in real-world use).
  2. Requires Krystal 1200 or 2400 DSP Engine - This is the first Microeditor release to require the Krystal DSP Engine which installs in a Pentium, Pentium II or Pentium Pro computer with PCI-bus motherboard. We held on for 8 years supporting the older DSP board, it was time to upgrade.
  3. Requires Windows 95 - Version 5.0 use a Virtual Device Driver for full Windows 95 32-bit operation. This version and all higher will not run under Windows 3.1x. Version 5.0 does not run under Windows NT 4.0.

Version 5.0 Bug Fixes

Page Top
 
 
Email to a Friend | Bookmark This Page | Google MTU Map | Policies | Microsound

Hoster® is a Registered Mark of Micro Technology Unlimited.
Trademarks of Micro Technology Unlimited; MTU, Karaoke Pro, KPro, KHPro, Karaoke Home Producer,
DNoise, Keyrite, MicroCD, Microeditor, Microsound, Microstudio, Microtools, Songverter, Vogone.

Prices and specifications subject to change without notice
Copyright© 2000-20015 by Micro Technology Unlimited, All Rights Reserved