karaoke software for windows 7, Vista, XP
Sales Call/Text:
919-870-0344
Karaoke Software for Everyone
Including Singers & Hosts
Vocal Removal Tools

Remove Vocal Example Songs

Fall Specials!
25% off all NEW Software!
Coupon Code:
92516
10% off all MTU Karaoke Ultrabook Systems
Remaining: 


Microeditor 2.7b-2.4 Software Changes

Version Release Date
V5.3-V5.5 June 24, 2002 & Prior
V5.0-V5.2c August 20, 1999 & Prior
V2.7b May 20, 1997
V2.7a March 18, 1997
V2.7 March 6, 1997
V2.6a January 30, 1997
V2.6 January 10, 1997
V2.5d December 9, 1996
for ICCA
V2.5c July 26, 1996
V2.5b April 3, 1996
V2.5a February 19, 1996
V2.5 December 19, 1995
V2.4a July 27, 1995
V2.4 May 16, 1995

Version 2.7b

This is the last release to run on the Microsound AT-DSP56 ISA-bus board.

Microeditor 2.7b requires an SVGA resolution display and uses color. If the whole Microeditor screen does not appear, configure Windows to use the SVGA 800x600 resolution Video driver. V2.7b fixes several bugs as a result of transitioning from the older Microsound AT-DSP56 board to also supporting the Krystal DSP Engine. V2.7b runs under Windows 3.11 or Windows 95 in 16-bit operation. The changes are NOT described in the 2.7 manual, but are in the 5.0 manual.

FOLLOW THESE STEPS if installing 2.7b to run with a Microsound AT-DSP56 Rev-J board or you will see Unable to access Microsound device and Microeditor will terminate. Ignore this if installing to run with a Krystal DSP Engine.

Microeditor 2.7 software requires an SVGA resolution display and uses color. If the whole Microeditor screen doesn't appear, configure Windows to use the SVGA 800x600 resolution Video driver. It is the first release to run with a Krystal DSP Engine, but it can run on the Microsound AT-DSP56 Rev-J board also. The 2.7 manual describes this release. V2.7a contains new features which the 2.7 manual does NOT describe, but the 5.0 manual does.

FOLLOW THESE STEPS if installing 2.7 to run with a Microsound AT-DSP56 Rev-J board or you will see Unable to access Microsound device and Microeditor will terminate. Ignore these instructions if you are installing to run with a Krystal DSP Engine.

Version 2.7b New Features

  1. Audition Play Lock -The Audition and 2X Audition stop function can now be defaulted to transfer to the spacebar after a settable timeout. Play then continues without holding the mouse button. At any point, pressing Spacebar will terminate playback regardless of whether or not the mouse button is still down.
  2. Scrub Play Lock - The Scrub stop function can now be defaulted to transfer to the spacebar after a settable timeout (different from Audition).
  3. Comma is Marking hot-key - Pressing this while playing, stops play and sets a marking anchor point, with marking now following the play cursor. This is the same as shift-right clicking the Mark icon.
  4. Period key inserts Skip Zone - Pressing this key while playing stops play and inserts a skip zone ending at the location where the key is pressed. If marking exists (pressing the Comma key before), the marked area is used. Zone defaults apply.
  5. Divide key ( / ) inserts Amp Zone - Pressing this main keyboard (not the numeric pad key) key while playing stops play and inserts an Amp zone at the location where the key is pressed. If marking exists (pressing the Comma key before), the marked area is used. Zone defaults are used.
  6. Multimedia Device Driver defaults save to disk - Under Windows 95, selecting Analog, AES/EBU or SPDIF for the multimedia driver play and record ports saves to disk when you exist Microeditor. The prior setting automatically loads when run again. Changing it during a session and exiting modifies the startup default.

Version 2.7b Upgrade Features

  1. Opening a Project (MIX) with a Newer Backup (MBK) File - This feature now automatically deletes the .OLD file if it exists from a prior restore of the MBK file. With frequent power losses or computer crashes, this allows using Microeditor with maximum efficiency and without fear of loss of work.
  2. Select Krystal I/O or Microsound External I/O Module - The Default menu I/O options command has new radio buttons to select between Krystal I/O or external I/O Module to use with Analog, AES/EBU or SPDIF ports. Krystal and I/O Module ports cannot be used together.
  3. Increased Windows 95 & NT Focus - MTU is porting Microeditor to fully run on Windows 95 in several steps. Microeditor 2.7b uses a Virtual Device Driver to become 95 compatible. Microeditor 5.0 will be a 32-bit application requiring Windows 95. If you don't need Windows 95, wait until Microeditor 5.1 fully supports Windows 32-bit operation.
  4. Larger DSP Play Buffers - The Krystal (not Rev-J board) SRAM play buffer was doubled to prevent underruns when Windows 95 is slow providing audio samples.
  5. Microeditor Play Buffers - The Pentium-side play buffers more efficiently use memory to help avoid underruns. This works with both Krystal and Rev-J DSP boards.

Version 2.7b Bug Repairs

  1. MIDI Note Trigger - In the Record New Audio Segments dialog, any MIDI Note trigger may now be used. Earlier only C3 on channel 1 would work.
  2. Compressor/Limiter Command - The Preview button now recalculates after changing from RMS to Instantaneous mode when using mono sound files.
  3. Scrub Play Crashes - Previously this would cause a GPF with no Project open or a zero length project.
  4. Scrub in Reverse - This no longer crashes. Previously, under certain conditions, it could cause a GPF.
  5. 6% Scrub - The 6% scrub button now plays 6% sampling rate with all I/O selections. It use to play 100% with some.
  6. Save As Segments Command - When requested, this now correctly ignores muted and group muted segments which earlier were ignored.
  7. Normalize Command - When requested, this now correctly ignores muted and group muted segments which earlier were ignored.
  8. Record New Audio Dialog - Recording with a non-zero duration no longer causes the next project recording to fail.
  9. Scroll View Window With Left Keyboard Arrow - The left keyboard arrow search function moves the play cursor and scrolls the view window to the segment containing the selected Item. Previously, the display would fail to scroll, but the item would draw in the display without being attached to a Segment.
  10. Create Screen Play I/O Port Field- This now displays correctly in this screen. Previously, it displayed AN regardless of the setting inherited from the project screen.
  11. Audition Play With Krystal Digital I/O - This now properly plays a mono file or project.
  12. I/O Selection Command - This now works properly when the I/O module is selected and it does not have a Digital Audio I/O board. Previously setting the record audio port to digital could hang the DSP and Microeditor would abort the command.
  13. Recording From Krystal Digital I/O and Monitoring Analog - Previously following this operation, subsequent recording from the I/O Module would fail the first time.
  14. Recording Krystal Analog I/O - Previously, following this operation, the second use of record with monitor or play/record using Krystal or I/O module digital I/O would hang at the end of the recording.
  15. Save As Segments Command - Saving in 8-bit Linear AIFF file format now saves correctly. Saving in compressed mu-law format also now works. Previously some portions of the mu-law data could be written incorrectly.

Version 2.7a

Microeditor 2.7a software requires an SVGA resolution display and uses color. If the whole Microeditor screen doesn't appear, configure Windows to use the SVGA 800x600 resolution Video driver. It is designed to run with a Krystal DSP Engine, but it can run on the Microsound AT-DSP56 board. V2.7a contains new features which the 2.7 manual does NOT describe, but the 5.0 manual does.

FOLLOW THESE STEPS if installing 2.7a to run with a Microsound AT-DSP56 Rev-J board or you will see Unable to access Microsound device and Microeditor will terminate. Ignore this if installing to run with a Krystal DSP Engine.

Version 2.7a New Features

  1. SMPTE Frame Rate and Drop Frame status save with Project - The project SMPTE frame rate now saves with the project. Opening a project with these in the header automatically sets these selections, overriding the screen selection.
  2. SMPTE Drop Frame status verified - When playing under MicroSync control, if the incoming SMPTE Drop or Non-Drop frame status does not match the selected SMPTE frame rate an error message appears and play terminates. In the Record New Audio dialog, if SMPTE triggering with MicroSync is enabled and the Drop Frame indication does not match the selected SMPTE Frame Rate, an error message appears and the record operation terminates.
  3. Screen Fields Show Green Text on a Black Background - The Project and Create Segment screen fields, Record New Audio dialog fields, and Time Control fields now show these new colors.
  4. MSND.DLL changed to MTUMSND.386 Virtual Device Driver - This device driver now works with both the Microsound Rev-J DSP board and the Krystal DSP Engine. It also now supports a SYSTEM.INI [Microsound] section line to allow specifying alternate I/O Module crystal sample rates for film pull up/down.

Version 2.7

Microeditor 2.7 software requires an SVGA resolution display and uses color. If the whole Microeditor screen doesn't appear, configure Windows to use the SVGA 800x600 resolution Video driver. It is designed to run with a Krystal DSP Engine, but it can run on the Microsound AT-DSP56 board. The 2.7 manual describes this release.

FOLLOW THESE STEPS if installing 2.7 to run with a Microsound AT-DSP56 Rev-J board or you will see Unable to access Microsound device and Microeditor will terminate. Ignore this if installing to run with a Krystal DSP Engine.

Version 2.7 New Features

  1. Virtual Device Driver (MTUMSND.386) - Because of upgrades to this driver, the CONFIG.SYS file EMM386 X=DC00-DFFF line is no longer required. Also, the SYSTEM.INI file EMMEXCLUDE=DC00-DFFF line is no longer needed. Earlier versions required these entries to work correctly.
  2. Krystal I/O and External I/O Module - Microeditor supports using Krystal I/O only, or External I/O Module I/O only, but not sharing them at the same time.
[mtu customer support page]

Version 2.6 and V2.6a

Microeditor 2.6a had no significant changes from 2.6, which requires an SVGA resolution display and uses color. If the whole Microeditor screen doesn't appear, configure Windows to use the SVGA 800x600 resolution Video driver. It runs only on the Microsound AT-DSP56 board Revision-J.

Version 2.6 New Features

  1. Compressor/Limiter... Command - This EFX menu command processes individual segments in a project. It computes a new sample stream on disk that links as a new layer on the segment, playing instead of the master sample file (or layer below it).
  2. Combine Group Segments Command - This Segment menu command duplicates a group bus on a mix console. All the segments in the selected group submix to disk, a new segment creates and hides the subsegments. The new segment allows editing and adding effect layers, or uncombining to re-engineer any time. Thousands of segments can be in a combined group,but no more than 20 can overlap and combine. Each of these 20 can be a combined segment with 20 combined subsegments, etc. for infinite sound mixing.
  3. Uncombine Group Segment Command - This Segment menu command reverses a combined segment, removing the substitution sample layer and edits, restoring the subsegments for remixing.
  4. Save as Segments... Command - This File menu command saves each segment in the project as a separate sample file on disk. Selectable file formats are: SF, Wave, AIFF, or SND (headerless). Selectable compression can be; none (16-bits), linear 8-bit, or mulaw 8-bit. An entered seed name automatically increments for each file for unattended operation.
  5. Split Project Command - This File menu command splits a project at the play cursor, creating two new projects.
  6. Move Lock Disable Command - When enabled, this Utilities menu command temporarily overrides segment lock for moving one time (disabled after the operation). Ctrl-click and drag move the segment and all following it, even if locked also move.
  7. RP Icon - This icon and Play menu Record/Play command enables simultaneous recording while spacebar playing, replacing the Overdub and Punch In/Out icons. There are three colored states; gray (play only), green (record triggered manually), and red (record auto triggers at marking or a selected zone). It works with the TC icon which enables timecode Chase Lock play, replacing the Enable Record While Chase Lock Playing command.
  8. TC Icon - This icon and the Play menu Enable TimeCode command enables spacebar play to chase lock play to SMPTE or MIDI timecode. In Edit mode, only the selected segment plays to timecode. This requires a MicroSync or SMPTE/MIDI board. The TC and RP icons allow recording in sync to timecode.
  9. Handle Length - This field (and enable clickbox) in the Display Defaults command enables the R/P icon green (auto-trigger) mode to start and stop recording the Handle Length before and after a marked area or a selected zone.
  10. Auto-Compare MIX to MBK File - Many users have never seen that auto backup occurs every 60 seconds. Opening a MIX project file, Microeditor now compares the date and time stamp to its backup MBK file. If the MBK is later, a warning appears with instructions. This happens with a power loss or computer malfunction, or changes were made and the project not saved on exit. This feature insures no material is ever lost... the ultimate in security to insure maximum creativity always.
  11. MIDI Channel/Note Trigger added - The Trigger field in the Record New Audio dialog now contains a MIDI Channel/Note selection. This allows triggering record using the selected MIDI Channel number and Note code. This appears only with an optional SMPTE/MIDI card installed.
  12. Selected Group Changes Color - All segments in a group turn magenta when one is selected (it is red). If the Group Disable Icon is yellow (enabled), grouping is diabled and only the selected segment changes color.
  13. Cursor Arrow Shapes - Three new shapes exist for the mouse cursor when moving multiple segments, moving a locked segment when the Move Lock Disable command is active, or moving multiple locked and non-locked segments.

Version 2.6 Upgrade Features

  1. Chase Lock, Chase Lock Segment and Enable Record While Chase Lock Play Commands - These Play menu commands are deleted as the TC icon now controlls playing and recording in sync to timecode.
  2. Fade Defaults- The Fade Default ramp and duration apply to segments created by copying a segment, created with the Record button or created by recording during Chase Lock.
  3. F12 Key - Pressing the F12 key places diagnostic date for the open project in the clipboard, including the Command list and Play list and sample files used.
  4. + and - Keys - The main keyboard + and - keys now work for zooming in and out. Pressing them multiple times termintes waveform redraw until the final level.
  5. Hot Key Codes - The EFX menu EQ command hot key is now Q (E conflicted with Effect Send). The Record New Audio Segments dialog Timecode field is T (M conflicted with Mute).
  6. Digital Audio Output - On 4 channel analog plus digital I/O Modules, audio played out digitally playsout channels C and D also. If digital is used, audio played out C and D also goes out digitally, regardless of the sample rate.
  7. Skip Zones - When the Default menu Zone Defaults command Auto Adjust Skip Zone clickbox is enabled, a warning dialog box appears if Microeditor unable to automatically adjust one or both marked ends.
  8. Compact Project Command - When compressing the default sound files, all of the computed samples for a segment with effect layers are kept, even if the segment was shortened.
  9. 999 Groups - Microeditor now supports up to 999 groups. If 3 digit Group numbers are used in a Project, it is not downward compatible with Microeditor 5.0(_.a, b, c).
  10. Group & Segment Mute Indicators - An 'M' in front of a segment group number indicates group mute. An 'M' following a group number (or no group number) indicates segment mute.
  11. Multimedia Device Driver - The play or record delay now only occurs when the sample rate changes. It is 83ms at 48kHz, or 500ms at 8kHz. Note: adust theoffsets if accounted for in other programs.
  12. Segment Display Order - Segments display in the View window are now controlled by starting time order, then the segment length, then the group# assignment, then track 1 and 2 assignments, and lastly the segment internal ID code.
  13. Position Window Renamed to Project Clipboard - Everyone called it the clipboard, so do we now. It is also changed in all dialog boxes referring to it.
  14. Solo Button Renamed to Edit Button - The Solo Mode command changed to Edit Segment View command. This still displays the selected segment in waveform view. Also if the View window moves beyond the segment, it deselects and terminates Edit view.
  15. Segment Screen Renamed to Create screen to properly indicate its function. The Project screen Create Segment command changed to Create Screen command.
  16. Audition Play Delayed - This delay is now 200 milliseconds to make releasing the right mouse button easier to set the play cursor at the mouse arrow.
  17. Message Numbers - Unique numbers appear in all Microeditor message boxes to allow foreign users to document the meaning in their language. A disk copy of the messages and numbers is available upon request.
  18. Microeditor runs on Krystal DSP engine - Microeditor 2.6 uses a new Virtual Device Driver (VXD) to run on the older ISA-bus Microsound DSP56-AT board and the new PCI-bus Krystal DSP Engine. V2.6 is the last release for the older DSP56-AT board - 7 years is a long time supporting one hardware technology. However, only the DSP board needs to upgrade as part of MTU's commitment to our customer's best interests.
  19. V2.0 to V2.5c Projects - Project files created with Microeditor V2.0 through V2.5c are upward compatible with Microeditor V2.6. However, files saved under V2.6 must translate to be downward compatible.

Version 2.6 Bug Repairs

  1. VU meters in Record New Audio Segments dialog box now appear correctly. After right clicking the Rec button the third time, they would not function. Also, operations in this dialog box that resulted in a GPF error have been fixed.
[mtu customer support page]

Version 2.5d

Microeditor 2.5d upgrades an existing 2.5c installation. Version 2.5d does not have an install program. It runs only on the Microsound AT-DSP56 board Revision-J. These features are not described in the 2.5 manual, but they are in the 2.6 manual.

Version 2.5d Upgrade Features

  1. MicroSync options now store as startup defaults.

Version 2.5c

Microeditor 2.5c upgrades an existing 2.5b installation. Version 2.5c does not have an install program. The MEDIT.EXE and CSF.DLL programs copy over the existing 2.5b installation files. It runs only on the Microsound AT-DSP56 board Revision-J. These features are not described in the 2.5 manual, but they are in the 2.6 manual.

Version 2.5c New Features

  1. Mouse Center Button - Click & drag this button (requires a 3-button mouse) across an area in a selected segment marks the area. Releasing the button inserts an enabled skip zone using zone defaults. The Display menu Display Defaults command has a clickbox to enable playing the Pre/Postroll length before and after the zone.

Version 2.5b

Microeditor 2.5b release has one upgrade which the 2.5 manual does not describe. It fixed several bugs that a few clients hit. It was sent out for new production orders and to those who experienced the bugs. It runs only on the Microsound AT-DSP56 board Revision-J.

Version 2.5b Bug Repairs

  1. Skip Zone - When this zone is inserted with the Zone Default command Auto Adjust Skip Zone clickbox enabled, a message appears if either end cannot be automatically adjusted.
  2. Compressing the default sound files with the Compact Project command, now all segment substitution sample layers are kept, even for shortened segments. Previously, shortening a segment with layers would remove samples not currently pointed to by the segments.
  3. Record New Audio Segments dialog box operations previously would stop responding after the Pause button was clicked many times. Routines were fixed that detect termination during play and record now prevent the Windows queue from filling with unnecessary keyboard and mouse messages.
  4. Auto-loading a project from a customized Microeditor icon, now displays the Positioning window contents correctly. Previously, the Positioning window would never appear.
  5. Splitting a segment inside an amp zone now works correctly. Previously, the amp zone in the second segment would be shorted by an amount equal to the amp zone ending fade.
  6. Keyboard and mouse queue in Windows could fill up with unnecessary keystrokes and clicks while recording or playing. This now works correctly. Previously, the play or record commands would cease to respond after the queue was full.

Version 2.5a

Microeditor 2.5a was a rapid release to fix several bugs, sent free to registered V2.5 users. It runs only on the Microsound AT-DSP56 board Revision-J.

Version 2.5a New Features

  1. Non-numeric pad + and - keys zoom the View window in and out respectively. Pressing either while the waveform is scanning terminates the scan and begins drawing at the new zoom.

Version 2.5a Upgrade Features

  1. Default fade ramps now apply to Segments created by left and right clicking the Record button as well as segments created by recording during Chase Lock.
  2. Project buffers sizes appear at the beginning of the clipboard data when F12 is pressed with an open project.
  3. EFX menu EQ command hot key is now Q to avoid conflict with the Effect Send command.
  4. Record New Audio Segments dialog box time code field hot key is now T to avoid conflict with the Mute clickbox.
  5. Terminating Chase Lock while recording will create a segment of the material recorded before termination.

Version 2.5a Bug Repairs

  1. Record during Chase Lock no longer hangs when creating the segment.
  2. In the Positioning Window, deleting the last segment when it had a selected item works. Previously a subsequent edit which updated the display could cause problems.
  3. Stereo segments in a mono project with real-time fade and gain changes but no track assignments now mix correctly.
  4. EFX menu commands now work correctly on stereo segments from mono files.
  5. EFX menu EQ command High Pass fader setting now works correctly when previewing the EQ or storing to disk.
  6. Opening projects prepared with Microeditor 2.3 and earlier would display an error dialog and the project would not load. They now load successfully.

Version 2.5

Microeditor 2.5 software was the last release before starting to port Microeditor 2.6 to run with a Windows 95 Virtual Device Driver (VXD). The code development entered a state that prevented a major release. This is why there are a, b, c and d releases. V2.5 requires a color SVGA display and 8MB RAM in the computer, and runs only on the Microsound AT-DSP56 board Revision-J. If the whole screen doesn't appear when Microeditor runs, configure Windows to use the SVGA 800x600 resolution Video driver.

Version 2.5 New Features

  1. Substitution Samples Implemented for Segments - This upgrade is used by all EFX menu commands that add effects to segments. It replaces a selected segment (including its' zones, fades, gain changes, etc.) with a new single block of samples stored on disk that now play instead of the original segment and its edits. The created segment inherits the Segment, Mute and Lock, and Group Mute status of the underlying segment. The new segment can be edited without restrictions with unlimited multiple layers allowed. The EFX menu Remove Last Effect command will peel off the top layer, restoring the prior segment or layer with its edits. This frees the substituted sample storage on disk and discards any edits applied to that layer. Be careful as this cannot be undone! If in question, copy the Segment first.
  2. EFX Menu - This menu holds effects commands for Segments.
  3. Burn Edits To Segment Command - This EFX menu command allows encapsulating the edits on a segment, replacing them with a single block of samples stored on disk equal to the original edited segment. This requires disk space to hold zones, fades, gain changes that can add to the new segment. This operation can be reversed with the Remove Last Effect command.
  4. EQ Segment Command - This EFX menu command adds Equalization to individual segments. Low Pass, three Parametric Band Pass and High Pass allow real-time adjusting the cut/boost while Preview playing. The center frequencies and Qs can be adjusted while not playing. Up to 30 presets can be saved with 30 character names. Edits prior to the command are encapsulated within, now playing the new samples.
  5. Invert Phase Command - This EFX menu command allows inverting the phase of either or both tracks within a segment. The negative waveform becomes positive and the positive becomes negative. Segment edits prior to the command are encapsulated within, now playing the new samples for the segment.
  6. View Effects Command - Since a segment can have multiple layers of internal effects applied, this EFX menu command will display each layer with a 30 character descriptor for each effect.
  7. Remove Last Effect Command - This EFX menu command allows deleting the last effect layer on a segment. It shows the 30 character effect descriptor to modify, delete or cancel. Removing this layer permanently deletes the effect and all zones, fades, gains added to the effect layer. Modifying allows adjusting from the existing parameters, or adding a new layer of the same effect.
  8. Effects Send Command - The Effects Send Icon is now duplicated by this command in the EFX menu.
  9. Grouping of Segments - This is a major upgrade to Microeditor! It allows assigning a Group # to individual segments. Then, all segments with the same Group number can be processed AS A GROUP for moving, locking, muting, gain adjusting and normalizing. This is the beginning of major future changes that you will love.
  10. Group # field and Button - The Segment Attribute dialog box now has a Group # field to receive a 2 digit number, assigning the segment to the entered Group number. It also contains the Show Groups Button. When clicked, it displays a numerical list of the currently used Group numbers and the name of the first occurring segment assigned to that Group.
  11. Establish Group # Default - Recording with the Record Button, Overdub Icon, Effect Send Icon or Punch In/Out Icon, when the Segment Attribute dialog box appears to create the Segment, if a Group # is entered it becomes the default. When a Segment is selected to play with these three Icons, its Group # is auto-assigned to any created Segments. The Create Segment command does not use this default.
  12. Group Menu - This contains commands and operations that work on group assigned segments.
  13. Mute/Unmute Group Command - This Group menu command will change the Group mute state of the selected group. Group muting is different from segment muting and does not affect segment muting. If the selected segment in the group is not muted, all segments in the group will be muted, or all unmuted if the selected segment was muted.
  14. Lock/Unlock Group Command - This Group menu command will lock or unlock all segments in the selected group. This uses the Segment lock mechanism, not a separate Group lock function.
  15. Disable Group Command - This Group menu command will disable Group assignment on all segments, turning the Group Disable Icon yellow.
  16. Enable Group Command - This Group menu command will enable Group assignment on all segments, turning the Group Disable Icon back to gray.
  17. Group Disable Icon - When this Icon is enabled (yellow background), all segments assigned to Groups are disabled from the Groups for purposes of gain changing, moving and normalizing. The Icon remains enabled or disabled until manually changed.
  18. Append Segment to Selected Marker - Both the Append Segment command and the Append Project command will append segments to a selected marker in the project if the Display Defaults command Append to Selected Marker clickbox is enabled.
  19. Enable Append Offset clickbox - The Display Defaults command has a new enable clickbox beside an Append Offset field. These allow specifying a plus or minus value to offset segments by when appending in the Project with the Append Segment command.
  20. Enable Append to Marker clickbox - The Display Defaults command has a new Enable Append to Marker field. This allows enabling or disabling appending a segment (with or without offset) or all segments from the appending project (without offset) to a selected marker.
  21. Trim To Mark Command - This command in the Project Screen Edit Menu shortens OR lengthens the selected segment to the mark area.
  22. Display Defaults Command now has Move Display - Auto - This allows setting the automatic display window scrolling as a startup default.
  23. Tab Key Moves View Window - Pressing the Tab key now shifts the View window 1/2 its width to the right. Shift Tab shifts 1/2 the width to the left.
  24. Command ID now used for Segment Identification - Segments now have unique ID numbers. This code platform upgrade allows many new features to be added in the future.

Version 2.5 Upgrade Features

  1. Moving Group Segments - When moving a segment, if it is in a group all segments in that group will move the identical amount. If the Group Disable Icon is ON, only the selected segment will move. The Append Segment command disables grouping to append the selected segment. Ctrl-click & drag disables grouping to open or close up space in the project.
  2. Normalizing Group Segments - All segments in a group can normalize individually or as a group.
  3. Group Segments in Positioning Window - Double clicking any segment (group assigned or not) in the View window place it in the Positioning window, where all group operations are ignored.
  4. Append All Segments from a Second Project as Groups - The Append Project command will copy all the segments from a second project into the open one. Group assignments are retained in the open project, mixing with existing groups with the same numbers.
  5. 64 Maximum Segment Overlap - Up to 64 mono/stereo segments can now be overlapped and statically mixed.
  6. Lock Segment Changes - Locking a segment now allows adding , moving, or deleting of; segment flags, skip and amp zones, as well as extending and shortening segments. Locked segments cannot: move, append, double click to Positioning Window, delete or split.
  7. Length Field in Solo Mode - While in Solo Mode (editing one Segment), the Length field now shows the length between the segment start and end markers, not the project length.
  8. Positioning Window Disappears in Waveform Views - Entering waveform view in either the project screen or solo mode, the Positioning window disappears to increase the waveform display resolution.
  9. Positioning Window Saves With Project - When a project is closed, segments in the Positioning window now save and reappear when that project opens.
  10. View Window Default Zoom - When a project is opened, the View and Positioning windows are zoomed out to show the entire project. This allows all segments in the Positioning window to be shown at their correct location relative to the project.
  11. Record Button Selectable for Mono or Stereo - Shift left-click the Record Button changes the title to Rec.A or Rec.AB to indicate recording mono or stereo into the project default .SF1 or .SF2 files. This also determines the default file used when right-clicking the Record Button displays the Record Button dialog box for more flexible recording.
  12. Play Cursor Moves While Recording - The play cursor now moves while recording with the Record Button. The Record Button places new segments at the play cursor start position, thus, they now append to each other instead of stacking up.
  13. Position Field While Recording - As the play cursor moves while recording, this field indicates its location. If the cursor is at the start of the project, while recording this shows the elapsed recording time. If it is interior to the project, this shows record from/to locations.
  14. Vertical Scroll Bars & Page Up & Page Down Keys - Clicking the vertical scroll bars above or below the current location box scrolls the View window up or down accordingly. The Page Up and Page Down keys now scroll the View vertically.
  15. Zoom Hot Keys - The + and - numeric keypad and the -_ and =+ keyboard keys are hot keys for the Grid Zoom icon. Some keyboards may not work correctly.
[mtu customer support page]

Version 2.4a

Released May 16, 1995

Microeditor 2.4 software (and higher releases) requires 8MB RAM, 1.4MB of disk space to install, requires a color SVGA display, and runs only on the Microsound AT-DSP56 board Revision-J. If the whole screen doesn't appear when Microeditor runs, configure Windows to use the SVGA 800x600 resolution Video driver. The waveform will not draw without at least 8MB RAM in the computer.

Version 2.4a Upgrade Features

  1. The Hot Keys in the Zone Defaults dialog box have been change to prevent conflicts.

Version 2.4a Bug Repairs

  1. Opening Project files created under 2.0 will now correctly upgrade to the 2.4 format. Earlier the upgrade was done incorrectly.
  2. Segment Attributes dialog box changes could earlier cause Microeditor to crash. This has been fixed.

Version 2.4

Version 2.4 Upgrade Features

  1. Recording Analog - Monitoring Digital - It is now possible in the Record Button dialog box to select to monitor on the Digital ports while recording on the Analog ports.
  2. Recording Digital - Monitoring Analog - The Analog output is now synchronized to the incoming digital sample rate clock so you no longer hear out of sync clicks or other distortions in the analog audio.

Version 2.4 New Features

  1. Project Screen Redesigned - The changes provide ultra efficiency, with all operations executing in one screen.
  2. Edit Screen Removed - Segment editing now is done in the Project screen with the Solo button changing to the Waveform view, showing only the selected segment.
  3. Record Screen Removed - The new Record buttons record in the Project screen for even easier use and efficiency.
  4. Non-linear Fade Ramps - In addition to Linear fades, there are now; Exponential, Log, Equi-power Sine, Full Sine, Sine-Cosine, ExpLog, LogExp. They all compute live on-the-fly while playing requiring no disk space or time to compute.
  5. Fader Controller - This on-screen slider instantly adjusts the gain on one or all segments in the Project.
  6. Normalize Command - This new command processes the amplitude of a selected Segment or all in the Project; independently or together.
  7. Buttons and Icons Dual Operation - Most buttons and icons now have two operations by left or right mouse button clicking.
  8. New Buttons Added - The new ones include: SkipZ, AmpZ, Create, Mix, Play, Mark Record, Pause, Monitor, and Vertical Waveform Scaling.
  9. 300 Element Peak Meters - These show extremely fine (0.2dB) resolution while recording and/or playing in the Project and Create screen (play only).
  10. 60 Files - Projects can now contain segments drawn from up to 60 sound and/or wave files.
  11. Save as SF, WAV and AIFF Commands - These can now save the entire project, a selected segment or a marked area of the project or segment.
  12. Copy Segment Operation - This now uses a marked area within the selected segment.
  13. Default SF1 and SF2 Files - Clicking the Record button will automatically create a Mono (SF1) or Stereo (SF2) default file for the open project. The old ISF filename extension is no longer used, but files with this extension continue to operate in projects.
  14. Play and Record I/O Fields - Clicking either of these on-screen fields toggles through the available I/O Ports to select the port to use.
  15. Disk Free Field - In the Project screen this shows the current available disk space for the open project sample rate and tracks.
  16. Help Icon - This on-screen icon makes accessing the help page for any item much easier.
  17. Scroll Icons - Located at either end of the Timeline, left clicking either scrolls the view window left and right clicking scrolls right.
  18. Scrub Buttons - These provide velocity scrub at 5 different rates from 100% (full sample rate) to 6% (1/16th rate).
  19. Microsound MultiMedia Sound Driver - This now supports all Microsound sampling rates.
  20. Backup to DAT Auto-saves first - The Backup to DAT command now executes the Save function to ensure the backup is up to date.
  21. Film Pull Up/Down Operation - Additional sample rates have been made available to do Pull Up/Down functions for working with film operations. This requires the MicroSync option board.

Version 2.4 Bug Repairs

  1. Cancel Copy Samples to Default File - Canceling during this operation in the Segment Attributes command or the Create Segments command would remove more samples from the default sound file than were written to it. This has been fixed.
  2. Save as AIFF Command - This command now writes a valid AIFF header.
  3. Recording File Flags - In the Record Button dialog box, using the Pause button no longer modifies the position of any recorded file flags.
  4. 4 Channel Projects and Digital Outputs - Playing 4 channel projects out the digital ports, audio assigned to tracks A and B now also plays out the digital ports.
[mtu customer support page]
 
 
Email to a Friend | Bookmark This Page | Google MTU Map | Policies | Microsound

Hoster® is a Registered Mark of Micro Technology Unlimited.
Trademarks of Micro Technology Unlimited; MTU, Karaoke Pro, KPro, KHPro, Karaoke Home Producer,
DNoise, Keyrite, MicroCD, Microeditor, Microsound, Microstudio, Microtools, Songverter, Vogone.

Prices and specifications subject to change without notice
Copyright© 2000-20015 by Micro Technology Unlimited, All Rights Reserved