karaoke software for windows 7, Vista, XP
Sales Call/Text:
919-870-0344
Karaoke Software for Everyone
Including Singers & Hosts
Vocal Removal Tools

Remove Vocal Example Songs

End of Summer Specials!
25% off all NEW Software!
Coupon Code:
92516
10% off all MTU Karaoke Ultrabook Systems
Remaining: 


 

Microstudio Version 2.613 to 1.000 Details

 

2.613 - Released April 26, 2006

  1. Supports Plextor 760 Drive - This newest drive is now supported.
  2. Vogone, Keyrite, KHPro Menu Commands - The Tabs that allowed locating the installed files and launching these programs were replaced by menu commands. When you click one, it automatically checks to see if its related program is installed. If so, it launches it, passing the Microstudio selected default Installation Folder to it so it becomes the default folder for that program. If the program is not installed, it displays a dialog box with text and a link to click to launch Internet Explorer to the associated product upgrade page where you can upgrade or purchase the program.
  3. Prevents Dual-Display Use - Microstudio was never intended to support dual-displays. This has now been removed. If you are running shows with Microstudio, you should buy Hoster or Hoster Lite.
  4. Requires Microsoft.NET Framework - Due to using the latest software development tools, Vogone 3.004 now requires the .NET Framework be installed. The Vogone installation program will help you install.NET Framework v2.0 (22MB file size) on your computer it is not currently installed.
  5. Installation Program Upgraded - You can now register using a Memory Stick or Floppy Disc if the computer is not on-line. Also, error messages sent down from our web site appear while registering if something is wrong. These explain many problems so you can correct them and continue registering.
  6. Security Scripts Updated - These are more forgiving than the prior security if you make minor upgrades to the computer Microstudio is installed on.
  7. Changed Version to 2.613
 

2.612 - Released October 01, 2005

  1. Support Plextor PX-716AL Burners - This new slot feed drive is now supported.
  2. The security has been updated in this version of the software. You should no longer receive the Serial Number does not Match Registration Information error under XP or 2000.
 

2.611 - Released April 29, 2005

  1. This version no longer Supports Windows 98 or ME. It will give you an error message stating this. It will give you a link that you can download Microstudio 2.609 from. This was the last version the security correctly worked under Windows 98 or ME.
 

2.610 - Released February 04, 2005

  1. Support Plextor 708UF and 716 Burners - These two recent drives are now supported.
 

2.609 - Released August 30, 2004

  1. Added .BIN File Support
    1. Microstudio can now use and create .bin files from other programs that support this extension for CDG format files. Please note that some other programs use the .bin extension for files that DO NOT contain the CDG graphic/lyrics data.
    2. BIN Support in Import Tracks Tab - The BIN button now selects to import CDG song tracks with a .bin extension. These are assumed to be .cdg format files, with the .bin extension added instead of the MTU standard .cdg extension. Microstudio will not allow importing a .bin file for any other than the CDG format to prevent confusion of our Karaoke CDG customers. You can add imported .bin files to an open Project file.
    3. BIN Support in Custom Assembly Tab - The Add HD Tracks button allows adding .bin files to the open project.
    4. BIN Support in Play Tab - The Add Track button in the Play Tab allows adding .bin files to the open project.
  2. Custom Assembly
    1. Select Multiple Tracks - You can now use the SHIFT and Ctrl keys to select multiple tracks to delete. The Remove All button was removed, and the Remove button was renamed to Delete. The UP and DOWN buttons will display an error message to select only one track when multiple are selected.
    2. Added Error Messages HTML Page - When you click the Write CD or Test CD buttons in the Custom Assembly Tab, if an error happens, a message box will appear describing it. The Help button will launch your Internet Browser and display a local HTML page of all Microstudio error messages. You can click here to view the latest version maintained at our web site and save it over your local copy in the Micro Technology Unlimited\Microstudio\Manual\Error Messages\microstudio.htm.
    3. FIXED: Delete Did Not Work - If you selected a track in the Custom Assembly Tab song list and clicked the Delete button, it disappeared from the screen, but it was still in the project in RAM and on the hard drive. This was fixed. The fields were also slightly rearranged. Also, if you selected a track and clicked the Up or Down buttons, it moved the track one location and deselected it. Selection is no longer removed.
    4. FIXED: Left: Field Overflow - When adding songs to the list, if the Left: field value was exceeded, a message box appeared multiple times for every cued up track to add to the list. We now clear all remaining cued up tracks at the same time so the message box appears one time.
  3. Import Tracks Tab - The Select/Deselect All buttons are now a Select all check box. The Import Selected Tracks button was moved below this check box to make it easier to know what to do next.
  4. Check MTU Site - This is now a command in the Help menu. The Check MTU Site buttons were removed from all screens.
  5. Speed Selection Now defaults to Auto - This Tools menu command had the Reader set to 8x speed and the Writer set to 6x speed. Both are now defaulted to Auto, which will allow the drive to tell Microstudio the maximum speed it can run at.
  6. FIXED: Play Stops when Another Program is Clicked - This problem was fixed earlier and reappeared in 2.605 and 2.606. It is fixed now.
  7. Upgraded Security Code - The standard MTU Security Code module was upgraded. The only change was to fix the "Serial Number mismatch" error when installing Microstudio in Windows 98SE or ME and there was no Network (Ethernet) card or port installed
  8. Installation Program Changes - In the installation program Registration screen, the Upgrade Registration Code field and associated instructions have been removed to prevent confusion.
 

2.605 - Released July 27, 2004

  1. Supports Plextor 712 DVDR Drive - Support drivers have been added for the latest 12x speed Plextor 712UF DVDR drive with exernal Firewire and USB 2 interfaces.
  2. Upgraded Manual and Version to 2.605.
 

2.604 - Released May 20, 2004

  1. Added Export .txt File Button - This button in the Custom Assembly Tab will export the list of songs in the Custom Assembly project as a .txt file to use for making a CD label. The filename (with .txt extension) is the same as the filename (less the .lst extension) of the current project open in the Custom Assembly tab that is being exported.
  2. Audio Continues to Play - When you click another program to make it the active window, Microstudio audio and video now continues to play.
  3. CDR Drive Identification Changes - Under rare conditions the CDR drives would not be identified correctly and thus not appear in the Detect Drives list. This was fixed.
  4. Detect Drives dialog box - This was changed to more accurately show YES only for drives that are useable for the CDG format. The new Information button launches a page with instructions how to test your CDR/DVDR drives for CDG use. The test-drive.htm manual is in the microstudio/manual folder if you want to look at it with your browser.
  5. Installation Program Now Reports Errors - During registration, if you type in the wrong registered email address, wrong registration code, or make other errors, an error message is now dynamically built at our web site for your specific error, sent back and displayed to you. Thus, if you have an error, you immediately see what is wrong. The errors are:

    1. "Each field requires an entry. Please enter all your required information, then click the Next button."
    2. "The Registration Code you entered is wrong. Please find your download instruction email with your Registration Code and enter it exactly as it appears."
    3. "You can install and register this product on [# allowed] different computers. Our records show it has already been registered on [# installed] different computers. If you feel this is in error, please email MTU Support with your registered email address and explain what the problem is. We will review your request and email you back what to do."
    4. "The email address you entered, [email], is incorrect. You must enter your registered email address found in your download instructions email for this product."
    5. "Your Registration Code has been disabled by MTU staff. There are various reasons that can cause this. If you feel we are wrong, you may email us with your request. If we have found your code has been given to others or posted on the Internet, you will need to purchase a new copy of the Product."
    6. "The Registration Code you entered is for a different product. Please find your download instructions email for the product you are installing and enter the Registration Code for that product."
  6. Modified Floppy Disc Registration Program - When your computer is not connected to the Internet, you can still register using a floppy disc on another computer. The program that Microstudio writes to the floppy disc was upgraded to perform better, and display an error message with suggestions if the registration attempt failed.
  7. Deleting Multiple Selected Tracks - In the Play Tab list box, you can now select multiple tracks using the Shift and Ctrl keys to delete them all at once with the Remove button.
  8. Added Remove All Tracks - In the Custom Assembly Tab you can now delete all tracks in the open Project at once with the Remove All button.
  9. CDR Drive Identification - Under rare conditions the CDR drives would not be identified correctly and thus not appear in the Detect Drives list. This was fixed.
  10. Fixed CDR Drives Wrongly Indicating CDG Capable - Some recent CDR drives would report they did the CDG format, but do not. In the Detect Drives button dialog box, they are now forced to report NO for Karaoke.
  11. Installs GDIPLUS.DLL File in Older Windows - This Microsoft file is required for installing Microstudio. It is now automatically added when installing into Windows 98SE, ME or Windows 2000. It is already available in Windows XP.
  12. Diagnostic Data Collected and Sent to MTU.com Web Site - Based on the types of problems that most users have, we are now collecting the Windows type, directx version, and video card at registration time about your computer. By already having this data, we can provide support faster if you ever need our help.
  13. Uninstall Prior Versions - This version will automatically uninstall these prior Microstudio versions: 2.314, 2.315, 2.400, 2.506, and 2.507-2.518.
  14. Check MTU Site - This button displays this page with instructions how to update to Microstudio 2.605.
  15. Drives Menu is now Tools Menu - This is more descriptive of the commands the menu contains. The Hot key is T.
  16. View Menu is removed - The View menu was removed. The single Status Bar command was removed, and the Status Bar now always appears at the bottom of the display.
  17. KPro Tab Changed to KHP - The KPro title was confusing because we are now shipping KHP (Karaoke Home Producer).
  18. Vogone Tab - The screen was upgraded slightly.
  19. Keyrite Tab - The screen was upgraded slightly.
  20. Failed to Disable Audio Alarms - The system sound now plays when 1) A track is imported in the Import Tracks Tab, 2) A disc is written in the Custom Assembly Tab, 3) A disc is written in the Duplicate Disc Tab. We are sorry, but we cannot disable this as it is controlled by an external program we use, but cannot control.
  21. Removed DirectX Info... command - This Help menu command is no longer needed so we removed it.
  22. Changed to Version 2.604.
 

2.517 Changes

Released 11/23/03
  1. 2.517 Added Error Checking for Email Spaces - If a space was added before or after the Registration Email, the product would install, but when run would display the error "Serial Number does not match registered Serial Number". We now remove any spaces before or after the Registration Email so this error will not happen again.
  2. 2.516 Added View Registration Code Command - This command displays your personal Registration Code used to install Microstudio on this computer. There was no way to determine this, especially if you owned several copies of Microstudio for multiple users. A bug displayed the Keyrite Code instead of Microstudio; fixed in 2.517.
  3. 2.516 Changed Installation Registration Email and Registration Code - The instructions for entering your registered Email and Registration Code were unclear. We moved the Email field to the Registration Code screen with more instructions where to find the exact entries to make. If you follow these, you will register your first try.
  4. 2.516 Install Modify and Repair now communicate with the mtu.com web site to insure we know which version you are running so we can help you if needed.

2.515 Upgrades

Released 11/10/03
  1. Fixed Bug in Install Program - One customer had a problem installing 2.514. We found the bug and fixed it in 2.515. Anyone with 2.514 should click their download link to get the new updated installation program file. Then, click either Modify or Repair to install it over the 2.514 version. If you have a version of Microstudio earlier than 2.514, you should click Remove to delete the prior version, then install 2.515.

2.514 Upgrades

Released 11/07/03
  1. Upgraded Installation Program for Dealers - Dealers can now install Microstudio. Each time Microstudio runs after that, when the computer is restarted it will launch the Microstudio installer (with cancel and register buttons) for the end user to register with their information, including their email address for MTU to send upgrade notifications to. Once they register, they can receive any free upgrades available and receive support from MTU.

2.508 Upgrades

Released 10/06/03
  1. Supports New CDG-DVD Recorder Drive - A new DVD+R/CDR burner is supported and available from MTU certified to do CDG disc formats. Microstudio does not support DVD yet.
  2. Change View Menu Display Mode Command - The Play Tab now shows a toggle up/down button to select Display Full Screen or Display Window. This replaces the older 8-bit full screen display.
  3. Bug Fixed in Play Tab - When there were no entries in the Playlist, clicking the Play button would lock up. It now terminates the play operation.
  4. Fixed Read Manual command
  5. Upgraded InstallShield - The default browser is launched to display a new instruction web page if an installation problem happens.
  6. Check MTU Site - This button displays this web page with instructions how to update Microstudio prior versions.
 

2.506 Upgrades

Released 08/12/03
  1. Faster playback and record times using our newest 52x CDR drive. Together, they decrease the time to read a CDG disc by almost 50% when duplicating.
  2. The Karaoke player was rewritten from ground up. It now supports any resolution playback, and works with your computer dual display card if you have this. It now uses less than 5% of the computer power, where before it consumed 100% while playing.
  3. New Installation Program reduces the size of the download file from 6MB to around 2MB! Requires connection to the Internet to complete installation. This can be from the machine being installed on, or using a floppy disc to register on any other PC that is on-line.
  4. Known Bug - The older 8-bit display mode window does not play correctly. Some users report it crashes, while others report it shows horizontal lines through the display while playing. This was replaced in 2.508 with our newest player code.
 
These Versions Install With a Serial Number, which was replaced by our newer Registration Code with Version 2.506.

Click here for versions 2.506 ahd higher

2.400 Upgrades

Released December 20, 2002
  1. Added New ASPI Drivers - These new drivers support the USB CD-Recorders that MTU now sells, and fix the bug that caused the computer to run slower and lock up after burning 2 or 3 CDR discs.
  2. Supports new Plextor 48x CDR Drives - Support was added for these new IDE or USB 48x write speed CDR drives.
  3. Fixed Nikkodo Discs double line display - This has been fixed now as we found the exact reason why it was happening.
  4. Fixed Party Tyme, Dangerous, All Hits, Pioneer, Nutech, others - Some discs caused play problems. We have fixed all known player problems.
  5. Fix CD Play problem - There was a problem discovered when playing from a CDG disc. It is now fixed.
  6. Spacebar and Esc Keys - The Spacebar key again stops play and advances to the next song in the Play List and the Esc key terminates the play screen if you are in single-display mode.
  7. Single/Dual Display Operation - The new player code will work with the new dual-display cards from ATI and NVidia (probably others). This allows you to place the Karaoke Preview Window on a separate TV display, and still have the Microstudio window on your computer monitor.
  8. Rewrite the play code - The play code has several limitations that we will expect to remove. These include:
    • Make it work with the computer's default display resolution
    • Make it work with 16-bit, 24-bit, and 32-bit color resolutions
    • Make it drive a TV monitor
    • Allow running as a resizeable, scaleable window, or in 320x200 full screen mode
    • Fix some anomalies in the internal code to handle Windows better
  9. The Manual Now Launches Internet Explorer - The manual now automatically launches the Internet Explorer browser every PC has available. Currently, the AOL browser does not like to open our manual so we use what we know will work. No, we don't love Microsoft, it is just better and safer than trying to develop for AOL only!

2.315 Upgrades

Released March 10, 2002
  1. Added support for new 40x CD Burners - This has been proven on the new 40X CDG certified burner MTU sells. Other non-CDG certified 40x drives are also supported.
  2. Sanyo CD Burner drives - These lower cost drives often do not work correctly for CDG. In the Detect Drives dialog box, Sanyo drives now show "No" for Karaoke and "Yes" for Audio. Too many users were buying Sanyo drives because the Microstudio demo said they could do CDG. We do not recommend Sanyo drives for CDG work as they write an inferior CDG disc with errors.
  3. Bug Fixed - In all prior versions of Microstudio if you imported a song as a .cdg to the hard drive using either the Import Tracks or the Custom Assembly Tab, and then clicked the WAV or Audio buttons and imported a .wav file, the .wav file was corrupted. The same happened if you first imported a .wav file and then a .cdg file. This has been fixed.
  4. Microstudio 2.315 demo - We have released a demo version of 2.315.

2.314 Upgrades

Released December 21, 2001

Installing 2.314 and prior versions

  1. New CDR Drive Support - Support has been added for the newest 24x and 32x write speed CD-Recorder drives. Some of them can read and write the CDG format.
  2. New USB CDR Drive Support - Support has been added for a new USB drive that MTU will offer for connection to Lap top computers, rated for 8x writing speed. To write above 2x speed requires at least a 300MHz processor speed and possibly a faster hard drive (7,200 rpm). We will update these requirements as they are identified. Currently, to work on Windows 2000 requires downloading a different ASPI driver.
  3. New ASPI Driver - New ASPI drivers have been added that should run with Windows 98, ME, and 2000. Installation is automatic, which can be done with other ASPI drivers already installed without any known problems. Microstudio automatically uses its driver.
  4. New ASPI Drivers... Command - This command displays a dialog box to allow selecting between the Default ASPI driver (typically Adaptec) or the MTU Installed driver. In version 2.314, to use a USB or Firewire drive under Windows 2000, you will need to download a different ASPI driver. Then, this dialog box allows you to select which ASPI driver Microstudio uses.
  5. BURN-proof command added to Drive menu - This new command enables/disables buffer underrun protection for newer drives that support burn-proof technology. These drives typically write a CDR disc at 12X or faster.
  6. Upgraded Installation Program - The Install program has been significantly upgraded. It automatically detects the Windows version it is installing in and makes all adjustments necessary. There are no more manual changes to make and the prior Internet Browser window no longer appears. However, the Installation version is now 5.2MB in size! We're not too happy with the latest InstallShield program as Microstudio 2.312 was only 1.6MB.
  7. Detect Drives Button - This button was added to the Play, Duplicate Disc, Custom Assembly, and Import Tabs. When clicked, it detects all CDR/CDROM drives and displays a dialog box with them in a list, and if they are able to read and/or write Audio CD and Karaoke CDG discs. If they do not support CDG, then a message informs the user this is why these drives do not appear in the Reading Drive or Writing Drive list boxes. This was added because some users did not believe that Microstudio was finding their CDR drives.
  8. KHPro & Vogone Tabs Upgraded - The fields for Version 1.0 in both these tabs have bee removed. The next release of Microstudio is expected to automatically launch these optional programs if you have them installed (this will require an upgrade to KHPro and Vogone to have their dialog boxes appear within the microstudio tabs)
  9. Microstudio Manual now HTML - The manual is now in web browser format, viewed by your default Internet browser on your computer. Some users objected to having to download the Adobe Acrobat Reader.


2.312 Upgrades

Released August 28, 2001
  1. Read Manual Command in Help Menu. This command will run the Adobe Acrobat Reader showing the 2.312 manual. This was done since we now deliver the software by download.
  2. Installation Directory is now C:\Program Files\Micro Technology Unlimited\Microstudio so it is with all other MTU installed programs.

2.311 Upgrades

Released July 06, 2001
  1. Bug Fixed - Default Project Folder Creation Failed. This error message could appear in Microstudio 2.310 and earlier. This would happen under a rare condition, but it would prevent Microstudio from running. Now when 2.311 runs, if it cannot open the default project folder name stored in the Windows Registry, it will create a new default project folder on the C drive called \songlist and run using it.

2.310 Upgrades

Released June 21, 2001
  1. Added 3 New Tabs for Vogone, KHPro and Keyrite to run these MTU programs from Microstudio. The Find button in each Tab allows selecting the directory and program name to execute. Thus, any files can be run. The selections appear the next time Microstudio runs.
  2. Karaoke Scrolling has been upgraded in the Play screen. Top to Bottom, Bottom to Top, Left to Right, and Right to Left scrolling now works. Please note: NUTECH discs have CDG coding that currently does not work with our Player program.
  3. Allow all CDR and CDROM drives to be selectable on all tabs where .wav files can be used. When CDG mode is selected in any Tab, the selected Reading and Writing drives are checked to make sure they are CDG capable. If they are not, a dialog box appears with instructions. The Reading Drive is analyzed first. When a valid CDG drive is selected, then the Writing drive is analyzed and the procedure repeats if required. IDE and SCSI Drives can both be installed on the computer and appear for selection.
  4. Added DirectX Info... command in the Help Menu that verifies the DirectX version on the computer. The Advanced button within the dialog box checks the display resolution of your video card.
  5. Show the Reading and Writing Speed fields were added in the Progress dialog box.
  6. Added Enable Caching command in the Drives menu. This enables using an advanced cache buffer while writing to a CDR disc that will improve performance with most CDR drives. If you have any problems with writing a disc, try disabling this option.
  7. Bugs Repaired a number of bugs were found and repaired that existed in 2.303.
[digital audio editing microeditor software links] 
 

2.303 Upgrades

Released May 29, 2001

Play Tab Changes

  1. Handle Missing Audio Card or Sound Device - In prior versions if an sound device was not installed in the computer the Play Tab was grayed out with no explanation. Now all features operate normally until you click the Play button. A dialog box appears with "Your computer does not have an audio card. Thus, you cannot play your selected Tracks. Please purchase and install an audio card so you will be able to play."
  2. Independent Project and Folder Settings - The selected folder is now independent of the selected folder in the Custom Assembly Tab. Also, the default folder presented when the Add Tracks button is clicked is the same as the last one used.
  3. Create Projects - Projects can now be created in this Tab from files stored on the hard drive. These are the same as Custom Assembly Projects and can be opened in either Tab. However, in the Play Tab a Project can exceed 80 minutes, which must be truncated to open it in the Custom Assembly Tab. When you click the Use Hard Drive button, the New, Open, Save, Save As, and the Select Track group Up, Down and Remove buttons become active. The TOC Refresh button renames to Add Track button to work allow adding files on the hard drive. Clicking Add Track shows the Open Files dialog box, which allows multiple files to be selected and added. Since Windows does not know the selection order, the Up/Down/Remove buttons allows moving the order of the songs. A new Total: field appears below the Add Track button and updates each time a new song is added or removed, always showing the Play Project length.
  4. Select Multiple Tracks to Play - When playing from a CD/CDG disc or files on the hard drive in a project, you can select multiple tracks/songs to play. The play order is always from top to bottom, not the selected order. If no selection exists, the entire CD/CDG disc or project will play starting from the first song. Whenever multiple tracks are selected, the Up, Down and Remove buttons will present an error message that only one track can be selected for the button to function.
  5. Select Hard Drive Button - This now shows the songs in the selected directory sorted alphabetically.
  6. Bug - The displayed track duration was off by 2 seconds because the pregap was not subtracted before the leading track.
  7. The Use CDR Drive - This list box was upgraded to only show installed CD Recorders capable of reading and writing the CDG format.
  8. Play Control Keys - While playing, pressing the Esc key will terminate the play operation and restore the control window. Pressing the Spacebar will terminate the song that is playing and start playing the next song.
  9. Check MTU Site button connects to our site to check for available upgrades and prices.


Added New Import Tracks Tab

This new tab allows importing multiple tracks at a time from a disc to the hard drive, and adding them to a custom assembly project or a play project.

Check MTU Site button connects to our site to check for available upgrades and prices.

CDG or WAV buttons select the file format to store to the hard drive.

Drive selects only CD-Recorders that can read and write the CDG format.

Select Folder selects where to store the Track files on the hard drive.

Read CD Tracks reads the CD Table of Contents (TOC), appearing in the Window below.

Auto Name allows auto-naming each filename with the Track number appended at the end. If disabled, you can enter unique song names.

Import Selected Tracks starts importing the selected tracks. Tracks stored on the hard drive show Imported.

Select All - Deselect All buttons selects all tracks read in from the CD, or removes selection on all tracks.

Sel - Select a Track
Trk - CD Track #
Duration - Track length
Filename - Enter a Track filename to store on the hard drive.
Status - Shows the status for each Track while importing as: Ready, Recording, Imported, Error or Aborted.

Add Tracks to: Custom Assembly Tab or Play Tab buttons. Once CDG or WAV tracks are imported, clicking either button checks to see if the open project in that Tab is the same file type (CDG or WAV), and if so adds all the imported tracks to it. If the types don't match, an error message appears. It allows adding the tracks multiple times if desired.

Error Checking and Instruction Messages - Significant upgrades were made to prevent user error, with many dialog and message boxes added for immediate feedback of what to do.

Change Import Format - Once files are imported from the CD disc as CDG or WAV files, clicking the opposite button (CDG/WAV) allows importing the same tracks in the new format, using the same filenames as the prior import.

Bugs Fixed - WAV format is now correct. Clicking the Remove button when no song is in the Project no longer crashes. If an audio card is not present, clicking the Play button presents a message box that you cannot play.

Auto Name Tracks - Improved the auto-naming option to insure users do the right operations in sequence.

Duplicate Disc Tab Changes

Error Checking - Much work was added to trap errors when a copy is in progress. If the operation fails, a dialog box appears to allow trying another copy or terminating. The disc image file does not have to be read in again. Once the last copy is made, the file is deleted.

# Copies Field has been removed. It is replaced by a sequence of dialog boxes that guide you through making more copies or terminating. Once a good disc image has been read to the hard drive, you can reuse it. When a copy is finished, a dialog box appears with a counter that indicates how many copies have been made. If a copy operation fails while burning, the dialog box warns that the copy operation failed, and allows terminating the operation or making another copy.

Auto Delete Image File - The disc image file read to the hard drive is removed after the user indicates the duplication is done.

Changed message texts - The message text in the dialog boxes now give clearer instructions.

Remove Auto Eject and Beep boxes and Change Operation - Auto-Eject is now always enabled. When the same CDR is used as the Reading Drive and the Writing Drive, eject the disc after the disc image has been copied to the hard drive and when the copied disc is finished. Beep when the disc image is done and when the copied disc is done.

The Check MTU Site buttons automatically connect to our site to show available upgrades and prices.

Custom Assembly Tab Changes

Independent Project and Folder Settings - The selected folder is now independent of the selected folder in the Custom Assembly Tab. Also, the default folder presented when the Add Tracks button is clicked is the same as the last one used.

Opening Play Tab Projects - The Play Tab allows creating projects, which can be longer than 80 minutes. These can be opened in the Custom Assembly Tab to write to a disc, but the disc write time cannot exceed 80 minutes. When the project opens, if it exceeds the value set in the Max Length: field, a dialog box appears to allow you to decide to make a copy of the project and save it in the same directory with the same name with a "b" appended before the extension. The project is truncated from the offending track to the project end and then opened, as the original is too long to open.

Change Working Folder - If the working folder (song directory) is changed, the open project links to the new folder. From version 2.216 this is independent of the working folder from any other Tab.

Change Selected Folder - Opening a new project from a different folder changes the selected folder and text field.

Import Track Dialog Box Text - Added a new message to use the Import Tracks Tab to bring in more than one Track at a time.

Check MTU Site button connects to our site to check for available upgrades and prices.

General Changes

  1. Bugs Fixed - The Play tab Refresh TOC button now works properly in Windows 2000 and NT. Extra checking was added to protect against crashing when no filename is entered in an operation. When opening a Project in the Play or Custom Assembly tabs, all files are verified to exist, and are presented to the use for removal from the list if missing. The track duration showing like 04:4294967295:40 has been fixed.
  2. Check MTU Site Button - This now uses the computer´s default browser (IE, AOL, Netscape, Opera, etc.) to visit the Microstudio Upgrades Web page.
  3. Install Program - The Operating System being installed into is detected and the correct installation notes displayed, and the appropriate config.sys file changes are made.
  4. Changed Field Colors - The fields requiring input now are black with green letters to snaz up the display.
  5. Upgrade Dialog Box Buttons - In some dialog boxes the Cancel button title was changed to No.
  6. Added Microstudio Icon - The multicolor CD icon appears in the upper left corner of the program screen, and when using Alt-Tab to switch between open programs.
  7. Close Sound Port After Playing - Earlier, the port was left open, preventing keyrite to play when Microstudio was open.

Changes in 2.200 from 2.103

Released 02/28/01
General Upgrades
  1. SUPPORT YAMAHA 2100 AND PLEXTOR 1610 BURNERS - Support for these 16x write speed drives have been added. NOTE: MTU does NOT recommend the Yamaha 2100 for CDG work.
  2. BUG - WOULD NOT WRITE FASTER THAN 6X - Microstudio would not write faster than 6x speed on some CDR drives. You can now write up to 16x speeds, if the computer and cd burner can write that fast.
  3. BUG - MICROSTUDIO RAN ONCE AND QUIT - A but caused the program to run one time and then quit. This has been fixed.
Custom Assembly Tab
  1. AUTOMATICALLY OPEN DEFAULT PROJECT - When you select the Custom Assembly Tab, it now automatically opens a default project in the current folder. Clicking the Select Folder button allows changing the folder and clicking the Save As button allows storing a new copy of the project in the new folder.
  2. Add Track From CD Button - This is now a dropdown selection box to select a CD Track by clicking a track number, using the numeric keypad or the top row number keys.
Play Tab
  1. DRIVE SELECTION - You can only select CDG capable CD-Recorder drives, not CDROM drives. Clients report problems because they were selecting a CDROM drive that did not read CDG discs.
[digital audio editing microeditor software links]

Changes in 2.103 from 2.014

Released January 10, 2001

Microstudio V2.103 was a major rewrite of much of the Microstudio V2.0 code. The causes of all random problems reported have been found and the code rewritten to overcome them. Version 2.1 plays every Karaoke CDG song that would not earlier play, and it plays them even on a Pentium 166MHz processor, with 1MB video RAM, direct-x/direct-draw version 1.0 (no longer requiring V7.0a or higher). In other words, this should play on just about any PC/Windows computer today.

General Upgrades
  1. Installs and runs under Windows 95, 98, ME, 2000 and NT4.0 SR4 or higher
  2. Supports up to 16x writing speed CD-Recorders. The computer and hard drive speed will determine whether higher than 8x can be successfully written to a high speed CD-Recorder. In some cases, it requires the hard drive and CDR drive to be SCSI devices, not IDE (ATAPI).
  3. Fixed a bug that searched for the CDR/CD-ROM devices multiple times. Earlier, if an error occurred while searching, it would flash the application screen up and immediately shut it down again, preventing it from running. It now runs always, even if it does not find a CDR drive.
  4. Filenames on the hard drive can now contain spaces.
Play Tab
  1. Now shows full screen view when playing instead of the small fixed window size.
  2. Allows selecting multiple tracks in the Track list from the disc TOC to play back-to-back. Also allows selecting multiple files on the hard drive to play back-to-back.
  3. Added custom exception handler to prevent crashes and display appropriate error messages when things go wrong.
  4. The Track list now properly clears when the disc is ejected so you cannot select a prior disc song track.
  5. Ejecting the disc while playing should no longer crash the program, but stop playing immediately and return to the Play tab from the Play window.
  6. Uses advanced security code that allows automated downloading via Internet.
  7. Added Refresh button to manually update the Tracks: field when a disc is changed.
  8. Automatically reads the disc TOC before starting a read operation. This prevents hanging that could occur when the user selected an invalid track from a prior disc TOC that has been changed.
  9. If an invalid track is passed to the play code an error message appears and forces a refresh of the TOC in the Track list.
Custom Assembly Tab
  1. Now allows selecting multiple files from the hard drive to add to the Song List.
  2. Now correctly loads pre-stored song lists from the hard drive back into the Song List. Earlier beyond 12 or more songs in the list would duplicate one name for every file in the display Song List, but properly write a new CD.
[digital audio editing microeditor software links]

Changes in 2.014 from 2.013

Released December 12, 2000
  1. A bug that tried to detect the CDR/CD-ROM drives multiple times was fixed. This showed up as preventing the program from running when executed. The hourglass would appear and disappear without the program window appearing.
  2. A logging operation was added to allow collecting diagnostic data as Microstudio ran.
  3. Click the Download button above to get this version. Your Microstudio V2.001 email and Serial Number codes will unlock this version.

Changes in 2.013 frm 2.001

Released November 9, 2000
  1. The drop dead security in V2.001 is removed that would prevent the program from running after 120 days.
  2. Click the Download button above to get this version. Your Microstudio 2.001 email and Serial Number codes will unlock this version.

Changes in 2.001 from 2.000

Released August 7, 2000
  1. A bug was fixed that would cause the program to stop running after 10 days.
  2. Click the Download button above to get this version. Your Microstudio 2.000 email and Serial Number codes will unlock this version.

Changes in 2.000 from 1.000

Released August 1, 2000

Microstudio V2.0 is a major upgrade. It includes a Play Tab to play Karaoke songs on your PC computer. It can duplicate Audio CD or Karaoke CD+G discs or allow making custom song assembled discs of either. Produced Karaoke CD+G discs can be used in any standard Karaoke machine that plays CDR media (Note: Only use CDR media. CDRW media will not work in Karaoke Players). Produced discs can also be used as a pre-production master for mass duplication. Produced Audio CD discs can play in any CD player that accepts CD-R media, and they can be used as a Red Book production premaster.

Note: Running under Windows 95 is not recommended as random problem have been reported that cannot be duplicated.

  1. The Play Tab was added to play Karaoke CD+G discs in the CD-ROM/CDR drive, or a .CDG file on the hard drive (copied there using the Custom Assembly Tab).

Changes in Microstudio 1.000 from Disc Architect

Released March 21, 2000
  1. The code was completely rewritten from Disc Architect, and is now a Windows 32-bit application with no DOS code.
  2. Separate Tabs exist for each function to make them easier to use.
  3. Current tabs include: Duplicate Disc and Custom Assembly with more tabs to come for option software modules that can be added.
  4. The Song Order List in the Custom Assembly Tab can be stored anywhere using the standard Windows File Open dialog box to select the drive and folder.
  5. Security protection has been added that prevents installing without the unlock codes.

Disc Architect 1.8c

Released April 14, 2000
Runs on Windows 95, 98SE, ME and a CD+G Certified burner from MTU.
 

Disc Architect 1.8b

Released March 13, 2000
Runs on Windows 95, 98SE, ME and a CD+G Certified burner from MTU.
 

Disc Architect 1.8a

Released December 22, 1999
Runs on Windows 95, 98SE, ME and a CD+G Certified burner from MTU.
 

Disc Architect 1.7

Released August 25, 1999
Runs on Windows 95, 98SE, ME and a CD+G Certified burner from MTU.
 

Disc Architect 1.6

Released April 19, 1999
Runs on Windows 98SE, ME and a CD+G Certified burner from MTU.
 

Disc Architect 1.5

Released February 5, 1999
Runs on Windows 98SE, ME and a CD+G Certified burner from MTU.
 

Disc Architect 1.4

Released January 2, 1999
Runs on Windows 95, 98 and a CD+G Certified burner from MTU.
 

Disc Architect 1.3

Released October 1, 1998
Runs on Windows 95, 98 and a CD+G Certified burner from MTU.
 

Disc Architect 1.0

Released April 7, 1998
Runs on Windows 95, 98 and a CD+G Certified burner from MTU.
 

MicroCDG 2.2

Released March, 1998
Runs on Windows 95, 98, Microeditor 5.1a and a CD+G Certified burner from MTU.
 

MicroCDG 2.1

Released November, 1997
Runs on Windows 95, 98, Microeditor 5.1a and a CD+G Certified burner from MTU.
 

MicroCDG 2.0

Released March, 1996

Runs on Windows 3.1x, Microeditor 2.5 and a CD+G Certified burner from MTU.

Other vendors and even Manufacturers do not test their drives for perfect CD+G performance. MTU tests each drive by burning 3 quality media discs to prove it is useable for professional use.

 
Click for current versions

Click for versions 4.006a to 3.000
[digital audio editing microeditor software links]
 
 
Email to a Friend | Bookmark This Page | Google MTU Map | Policies | Microsound

Hoster® is a Registered Mark of Micro Technology Unlimited.
Trademarks of Micro Technology Unlimited; MTU, Karaoke Pro, KPro, KHPro, Karaoke Home Producer,
DNoise, Keyrite, MicroCD, Microeditor, Microsound, Microstudio, Microtools, Songverter, Vogone.

Prices and specifications subject to change without notice
Copyright© 2000-20015 by Micro Technology Unlimited, All Rights Reserved